POST SMTP Mailer <= 2.5.6 - Cross-Site Request Forgery to Account Compromise

Cross-Site Request Forgery (CSRF)
CVE CVE-2023-3179
CVSS 6.5 (Medium)
Publicly Published June 26, 2023
Last Updated June 30, 2023
Researcher Erwan LR - WPScan


The POST SMTP Mailer plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 2.5.6. This is due to incorrect nonce validation on the resend_email() function. This makes it possible for unauthenticated attackers to resend emails to an arbitrary email address via a forged request granted they can trick a site user with the manage_postman_smtp capability into performing an action such as clicking on a link. An attacker could leverage this to resend a password reset email to their own account and compromise a site administrators account.



Vulnerability Details for Post SMTP – WordPress SMTP Plugin with Email Logs and Mobile App for Failure Notifications – Gmail SMTP, Office 365, Brevo, Mailgun, Amazon SES and more

Software Type Plugin
Software Slug post-smtp (view on
Patched? Yes
Remediation Update to version 2.5.7, or a newer patched version
Affected Version
  • <= 2.5.6
Patched Version
  • 2.5.7

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.