POST SMTP Mailer <= 2.8.6 - Reflected Cross-Site Scripting via msg

6.1
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
CVE CVE-2023-6629
CVSS 6.1 (Medium)
Publicly Published January 2, 2024
Last Updated March 20, 2024
Researcher Matan Berson (matanber)

Description

The POST SMTP Mailer – Email log, Delivery Failure Notifications and Best Mail SMTP for WordPress plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the ‘msg’ parameter in all versions up to, and including, 2.8.6 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link. CVE-2023-6621 appears to be a duplicate of this issue. CVE-2024-29128 appears to be a duplicate of this issue.

References

Share

Vulnerability Details for Post SMTP – The WordPress SMTP Plugin with Email Logs and Mobile App for Email Failure Notifications

Software Type Plugin
Software Slug post-smtp (view on wordpress.org)
Patched? Yes
Remediation Update to version 2.8.7, or a newer patched version
Affected Version
  • <= 2.8.6
Patched Version
  • 2.8.7

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.

Documentation