Post Snippets <= 3.1.3 - Cross-Site Request Forgery to Stored Cross-Site Scripting

Cross-Site Request Forgery (CSRF)
CVE CVE-2021-25010
CVSS 9.6 (Critical)
Publicly Published January 31, 2022
Last Updated January 27, 2023
Researcher Muhammad Adel


The Post Snippets WordPress plugin before 3.1.4 does not have CSRF check when importing files, allowing attacker to make a logged In admin import arbitrary snippets. Furthermore, imported snippers are not sanitised and escaped, which could lead to Stored Cross-Site Scripting issues



Vulnerability Details for Post Snippets – Custom WordPress Code Snippets Customizer

Software Type Plugin
Software Slug post-snippets (view on
Patched? Yes
Remediation Update to version 3.1.4, or a newer patched version
Affected Version
  • <= 3.1.3
Patched Version
  • 3.1.4

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.