Post Views Counter <= 1.4.4 - Cross-Site Request Forgery via save_bulk_post_views()

Cross-Site Request Forgery (CSRF)
CVE CVE-2024-31264
CVSS 4.3 (Medium)
Publicly Published April 5, 2024
Last Updated April 11, 2024
Researcher Brandon James Roldan (tomorrowisnew)


The Post Views Counter plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 1.4.4. This is due to missing or incorrect nonce validation on the save_bulk_post_views() function. This makes it possible for unauthenticated attackers to save bulk post views via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.



Vulnerability Details for Post Views Counter

Software Type Plugin
Software Slug post-views-counter (view on
Patched? Yes
Remediation Update to version 1.4.5, or a newer patched version
Affected Version
  • <= 1.4.4
Patched Version
  • 1.4.5

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.