Postie < 1.4.10 - Cross-Site Scripting

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
CVE CVE-2012-2580
CVSS 7.2 (High)
Publicly Published August 8, 2012
Last Updated August 7, 2023
Researcher loneferret


Cross-site scripting (XSS) vulnerability in the Postie plugin before 1.4.10 for WordPress allows remote attackers to inject arbitrary web script or HTML via the From field of an email. A partial fix was deployed in version 1.4.4 but this was easily bypassed.



Vulnerability Details for Postie

Software Type Plugin
Software Slug postie (view on
Patched? Yes
Remediation Update to version 1.4.10, or a newer patched version
Affected Version
  • <= 1.4.9
Patched Version
  • 1.4.10

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.