Replyable – Subscribe to Comments and Reply by Email <= 2.2.9 - Authenticated (Subscriber+) PHP Object Injection via prompt_dismiss_notice

Deserialization of Untrusted Data
CVE CVE-2022-4265
CVSS 8.5 (High)
Publicly Published February 8, 2023
Last Updated April 17, 2024
Researcher István Márton - Wordfence


The Replyable plugin for WordPress is vulnerable to PHP Object Injection in versions up to, and including, 2.2.9 via deserialization of untrusted input from the 'class' parameter used by the prompt_dismiss_notice AJAX action. This allows authenticated attackers, with subscriber-level permissions and above, to inject a PHP Object. No POP chain is present in the vulnerable plugin. If a POP chain is present via an additional plugin or theme installed on the target system, it could allow the attacker to delete arbitrary files, retrieve sensitive data, or execute code.



Vulnerability Details for Replyable – Subscribe to Comments and Reply by Email

Software Type Plugin
Software Slug postmatic (view on
Patched? Yes
Remediation Update to version 2.2.10, or a newer patched version
Affected Version
  • <= 2.2.9
Patched Version
  • 2.2.10

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.