PowerPack Pro for Elementor <= 2.10.17 - Authenticated (Contributor+) Privilege Escalation

Incorrect Permission Assignment for Critical Resource
CVE CVE-2024-3668
CVSS 8.8 (High)
Publicly Published June 7, 2024
Last Updated June 8, 2024
Researcher Ankit Patel


The PowerPack Pro for Elementor plugin for WordPress is vulnerable to privilege escalation in all versions up to, and including, 2.10.17. This is due to the plugin not restricting low privileged users from setting a default role for a registration form. This makes it possible for authenticated attackers, with contributor-level access and above, to create a registration form with administrator set as the default role and then register as an administrator.



Vulnerability Details for PowerPack Pro for Elementor

Software Type Plugin
Software Slug powerpack-elements
Patched? Yes
Remediation Update to version 2.10.18, or a newer patched version
Affected Version
  • <= 2.10.17
Patched Version
  • 2.10.18

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.