PowerPress <= 11.0.11 - Authenticated(Contributor+) Stored Cross-Site Scripting via Media URL

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
CVE CVE-2023-4820
CVSS 6.4 (Medium)
Publicly Published September 13, 2023
Last Updated October 4, 2023
Researcher Arganex Emad


The PowerPress plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the media URL in versions up to, and including, 11.0.11 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers with contributor-level and above permissions to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This issue was partially patched in 11.0.11, and fully patched in 11.0.12.



1 affected software package

Software Type Plugin
Software Slug powerpress (view on wordpress.org)
Patched? Yes
Remediation Update to version 11.0.12, or a newer patched version
Affected Version
  • < 11.0.12
Patched Version
  • 11.0.12

All the threat data shared in this database is powered by Wordfence Intelligence Enterprise.
Interested in integrating this data into your platform or network?
Contact us now to discuss API access to our Wordfence Intelligence Enterprise Data Feeds.

Inquire Now

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.