PowerPress <= 11.0.6 - Authenticated (Contributor+) Server-Side Request Forgery via wp_ajax_powerpress_media_info

Server-Side Request Forgery (SSRF)
CVE CVE-2023-41239
CVSS 5.4 (Medium)
Publicly Published August 29, 2023
Last Updated September 6, 2023
Researcher Mika


The PowerPress plugin for WordPress is vulnerable to Server-Side Request Forgery in versions up to, and including, 11.0.6 via the wp_ajax_powerpress_media_info AJAX action. This can allow authenticated attackers, with contributor-level permission and above, to make web requests to arbitrary locations originating from the web application which can be used to query and modify information from internal services.



1 affected software package

Software Type Plugin
Software Slug powerpress (view on wordpress.org)
Patched? Yes
Remediation Update to version 11.0.7, or a newer patched version
Affected Version
  • <= 11.0.6
Patched Version
  • 11.0.7

All the threat data shared in this database is powered by Wordfence Intelligence Enterprise.
Interested in integrating this data into your platform or network?
Contact us now to discuss API access to our Wordfence Intelligence Enterprise Data Feeds.

Inquire Now

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.