Pre-Publish Checklist <= 1.1.1 - Insecure Direct Object Reference to Arbitrary Post '_ppc_meta_key' Update

5.3
Authorization Bypass Through User-Controlled Key
CVE CVE-2023-44151
CVSS 5.3 (Medium)
Publicly Published September 22, 2023
Last Updated January 22, 2024
Researcher Rafie Muhammad - Patchstack

Description

The Pre-Publish Checklist plugin for WordPress is vulnerable to Insecure Direct Object Reference in versions up to, and including, 1.1.1 via the ppc_meta_box_ajax_add_handler and ppc_meta_box_ajax_delete_handler functions due to missing validation on a user controlled key. This can allow authenticated attackers with contributor-level access and above to modify and delete the '_ppc_meta_key' post meta value for arbitrary posts.

References

Share

1 affected software package

Software Type Plugin
Software Slug pre-publish-checklist (view on wordpress.org)
Patched? Yes
Remediation Update to version 1.1.2, or a newer patched version
Affected Version
  • < 1.1.2
Patched Version
  • 1.1.2

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.

Documentation