Premium Addons for Elementor <= 4.10.22 - Authenticated (Contributor+) Sensitive Information Exposure

Information Exposure
CVE CVE-2024-31278
CVSS 5.3 (Medium)
Publicly Published April 5, 2024
Last Updated April 11, 2024
Researcher Khalid


The Premium Addons for Elementor plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 4.10.22. This makes it possible for authenticated attackers, with contributor-level access and above, to extract sensitive user or configuration data.



Vulnerability Details for Premium Addons for Elementor

Software Type Plugin
Software Slug premium-addons-for-elementor (view on
Patched? Yes
Remediation Update to version 4.10.23, or a newer patched version
Affected Version
  • <= 4.10.22
Patched Version
  • 4.10.23

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.