Premium Addons for Elementor <= 4.10.28 - Authenticated (Contributor+) Stored Cross-Site Scripting via 'arrow_style'

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
CVE CVE-2024-3647
CVSS 6.4 (Medium)
Publicly Published April 24, 2024
Last Updated May 2, 2024
Researcher stealthcopter


The Premium Addons for Elementor plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's post ticker widget in all versions up to, and including, 4.10.28 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This requires the premium version of the plugin to be installed and activated in order to be exploited.



Vulnerability Details for Premium Addons for Elementor

Software Type Plugin
Software Slug premium-addons-for-elementor (view on
Patched? Yes
Remediation Update to version 4.10.29, or a newer patched version
Affected Version
  • <= 4.10.28
Patched Version
  • 4.10.29

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.