Premium Addons for Elementor PRO <= 2.9.12 - Authenticated(Contributor+) Stored Cross-Site Scripting via widget link

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
CVE CVE-2024-1996
CVSS 6.4 (Medium)
Publicly Published March 6, 2024
Last Updated May 31, 2024
Researcher wesley (wcraft)


The Premium Addons PRO plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's IHover widget link in all versions up to, and including, 2.9.12 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers with contributor-level and above permissions to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.



Vulnerability Details for Premium Addons Pro for Elementor

Software Type Plugin
Software Slug premium-addons-pro
Patched? Yes
Remediation Update to version 2.9.13, or a newer patched version
Affected Version
  • <= 2.9.12
Patched Version
  • 2.9.13

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.