Premmerce Redirect Manager <= 1.0.10 - Cross-Site Request Forgery via deleteRedirect()

Cross-Site Request Forgery (CSRF)
CVE CVE-2023-23787
CVSS 4.3 (Medium)
Publicly Published March 30, 2023
Last Updated August 21, 2023
Researcher Rio Darmawan - Zerobyte


The Premmerce Redirect Manager plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 1.0.10. This is due to missing or incorrect nonce validation on the deleteRedirect() function called via an admin_post hook. This makes it possible for unauthenticated attackers to delete redirects via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.



Vulnerability Details for Premmerce Redirect Manager

Software Type Plugin
Software Slug premmerce-redirect-manager (view on
Patched? Yes
Remediation Update to version 1.0.11, or a newer patched version
Affected Version
  • <= 1.0.10
Patched Version
  • 1.0.11

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.