Premmerce User Roles <= 1.0.12 - Missing Authorization via role management functions

Missing Authorization
CVE CVE-2023-41130
CVSS 8.3 (High)
Publicly Published August 24, 2023
Last Updated August 29, 2023
Researcher Nguyen Xuan Chien


The Premmerce User Roles plugin for WordPress is vulnerable to unauthorized modification of data and loss of data due to missing capability and nonce checks on the 'createRole', 'updateRole', and 'deleteRole' functions in versions up to, and including, 1.0.12. This makes it possible for authenticated attackers, with subscriber-level access and above, to create, modify, and delete custom roles.



1 affected software package

Software Type Plugin
Software Slug premmerce-user-roles (view on
Patched? Yes
Remediation Update to version 1.0.13, or a newer patched version
Affected Version
  • <= 1.0.12
Patched Version
  • 1.0.13

All the threat data shared in this database is powered by Wordfence Intelligence Enterprise.
Interested in integrating this data into your platform or network?
Contact us now to discuss API access to our Wordfence Intelligence Enterprise Data Feeds.

Inquire Now

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.