Pretty Links – Affiliate Links, Link Branding, Link Tracking & Marketing Plugin <= 3.6.3 - Cross-Site Request Forgery to Plugin Settings Update

4.3
Cross-Site Request Forgery (CSRF)
CVE CVE-2024-2326
CVSS 4.3 (Medium)
Publicly Published March 22, 2024
Last Updated March 23, 2024
Researcher Webbernaut

Description

The Pretty Links – Affiliate Links, Link Branding, Link Tracking & Marketing Plugin plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 3.6.3. This is due to missing or incorrect nonce validation when saving plugin settings. This makes it possible for unauthenticated attackers to change the plugin's configuration including stripe integration via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.

References

Share

Vulnerability Details for Pretty Links – Affiliate Links, Link Branding, Link Tracking & Marketing Plugin

Software Type Plugin
Software Slug pretty-link (view on wordpress.org)
Patched? Yes
Remediation Update to version 3.6.4, or a newer patched version
Affected Version
  • <= 3.6.3
Patched Version
  • 3.6.4

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.

Documentation