Prevent Landscape Rotation <= 2.0 - Cross-Site Request Forgery via adminpage.php

Cross-Site Request Forgery (CSRF)
CVE CVE-2023-48772
CVSS 6.5 (Medium)
Publicly Published November 28, 2023
Last Updated January 22, 2024
Researcher Nguyen Xuan Chien


The Prevent Landscape Rotation plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 2.0. This is due to missing or incorrect nonce validation on the adminpage.php file. This makes it possible for unauthenticated attackers to change the plugin's settings via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.



Vulnerability Details for Prevent Landscape Rotation

Software Type Plugin
Software Slug prevent-landscape-rotation (view on
Patched? Yes
Remediation Update to version 2.1, or a newer patched version
Affected Version
  • <= 2.0
Patched Version
  • 2.1

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.