Profile Builder <= 3.10.3 - Cross-Site Request Forgery via pms-cross-promotion.php

Cross-Site Request Forgery (CSRF)
CVE CVE-2023-47669
CVSS 7.1 (High)
Publicly Published November 7, 2023
Last Updated November 14, 2023
Researcher Brandon James Roldan (tomorrowisnew)


The User Profile Builder – Beautiful User Registration Forms, User Profiles & User Role Editor plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 3.10.3. This is due to missing or incorrect nonce validation on the wppb_activate_pms_plugin and wppb_deactivate_pms_plugin functions. This makes it possible for unauthenticated attackers to activate and deactivate arbitrary plugins via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.



1 affected software package

Software Type Plugin
Software Slug profile-builder (view on
Patched? Yes
Remediation Update to version 3.10.4, or a newer patched version
Affected Version
  • <= 3.10.3
Patched Version
  • 3.10.4

All the threat data shared in this database is powered by Wordfence Intelligence Enterprise.
Interested in integrating this data into your platform or network?
Contact us now to discuss API access to our Wordfence Intelligence Enterprise Data Feeds.

Inquire Now

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.