ProfileGrid <= 5.5.2 - Missing Authorization to Arbitrary Group Option Modification and Privilege Escalation

Missing Authorization
CVE CVE-2023-3714
CVSS 7.5 (High)
Publicly Published July 17, 2023
Last Updated July 18, 2023
Researcher István Márton - Wordfence


The ProfileGrid plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the 'edit_group' handler in versions up to, and including, 5.5.2. This makes it possible for authenticated attackers, with group ownership, to update group options, including the 'associate_role' parameter, which defines the member's role. This issue was partially patched in version 5.5.2 preventing privilege escalation, however, it was fully patched in 5.5.3.



Vulnerability Details for ProfileGrid – User Profiles, Groups and Communities

Software Type Plugin
Software Slug profilegrid-user-profiles-groups-and-communities (view on
Patched? Yes
Remediation Update to version 5.5.3, or a newer patched version
Affected Version
  • <= 5.5.2
Patched Version
  • 5.5.3

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.