ProfileGrid <= 5.8.2 - Bypass Group Members Limit

Improper Authorization
CVE CVE-2024-32774
CVSS 5.3 (Medium)
Publicly Published April 22, 2024
Last Updated April 29, 2024
Researcher Kyle Sanchez


The ProfileGrid – User Profiles, Memberships, Groups and Communities plugin for WordPress is vulnerable to group limit bypass in all versions up to, and including, 5.8.2. This is due to the plugin not properly verifying the limits of a group before adding a member. This makes it possible for authenticated attackers, with subscriber-level access and above, to bypass group limits.



Vulnerability Details for ProfileGrid – User Profiles, Groups and Communities

Software Type Plugin
Software Slug profilegrid-user-profiles-groups-and-communities (view on
Patched? Yes
Remediation Update to version 5.8.3, or a newer patched version
Affected Version
  • <= 5.8.2
Patched Version
  • 5.8.3

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.