Protect WP Admin <= 3.6 - Unauthenticated Plugin Deactivation

Incorrect Authorization
CVE CVE-2021-24906
CVSS 7.5 (High)
Publicly Published December 23, 2021
Last Updated January 22, 2024
Researcher Krzysztof Zając - CERT PL


The Protect WP Admin WordPress plugin before 3.7 does not check for authorisation in the lib/pwa-deactivate.php file, which could allow unauthenticated users to disable the plugin (and therefore the protection offered) via a crafted request



1 affected software package

Software Type Plugin
Software Slug protect-wp-admin (view on
Patched? Yes
Remediation Update to version 3.7, or a newer patched version
Affected Version
  • <= 3.6
Patched Version
  • 3.7

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.