Protect WP Admin <= 3.8 - Unauthenticated Information Disclosure to Protection Bypass

Information Exposure
CVE CVE-2023-3139
CVSS 5.3 (Medium)
Publicly Published June 12, 2023
Last Updated June 16, 2023
Researcher Daniel Ruf


The Protect WP Admin plugin for WordPress is vulnerable to information disclosure in versions up to, and including, 3.8. This is due to a data leak when performing a redirect after processing a crafted request. This makes it possible for unauthenticated attackers to disclose the URL of the admin panel and bypass intended protections.



1 affected software package

Software Type Plugin
Software Slug protect-wp-admin (view on
Patched? Yes
Remediation Update to version 4.0, or a newer patched version
Affected Version
  • <= 3.8
Patched Version
  • 4.0

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.