Protected Posts Logout Button <= 1.4.5 - Missing Authorization on pplb_options_save

Missing Authorization
CVE CVE-2023-25454
CVSS 6.5 (Medium)
Publicly Published February 16, 2023
Last Updated February 23, 2023
Researcher yuyudhn


The Protected Posts Logout Button plugin for WordPress is vulnerable to unauthorized deletion of data due to a missing capability check on the pplb_options_save function in versions up to, and including, 1.4.5. This makes it possible for unauthenticated attackers to update the plugin's settings. A nonce check was added in version 1.4.5, which does not address this issue properly. 1.4.6 adds a capability check.



1 affected software package

Software Type Plugin
Software Slug protected-posts-logout-button (view on
Patched? Yes
Remediation Update to version 1.4.6, or a newer patched version
Affected Version
  • <= 1.4.5
Patched Version
  • 1.4.6

All the threat data shared in this database is powered by Wordfence Intelligence Enterprise.
Interested in integrating this data into your platform or network?
Contact us now to discuss API access to our Wordfence Intelligence Enterprise Data Feeds.

Inquire Now

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.