Quick Page/Post Redirect Plugin <= 5.1.9 - Redirect Security Bypass

Improper Access Control
CVE CVE-2020-36699
CVSS 4.3 (Medium)
Publicly Published April 28, 2020
Last Updated June 7, 2023
Researcher Jerome Bruandet - NinTechNet


The Quick Page/Post Redirect Plugin for WordPress is vulnerable to authorization bypass due to missing capability checks on the qppr_save_quick_redirect_ajax and qppr_delete_quick_redirect functions in versions up to, and including, 5.1.9. This makes it possible for low-privileged attackers to interact with the plugin settings and to create a redirect link that would forward all traffic to an external malicious website.



1 affected software package

Software Type Plugin
Software Slug quick-pagepost-redirect-plugin (view on wordpress.org)
Patched? Yes
Remediation Update to version 5.2.0, or a newer patched version
Affected Version
  • <= 5.1.9
Patched Version
  • 5.2.0

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.