Direct Checkout – Quick View – Buy Now For WooCommerce <= 1.5.8 - Authenticated (Shop manager+) Stored Cross-Site Scripting via Custom CSS Code

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
CVE CVE-2023-47657
CVSS 5.5 (Medium)
Publicly Published November 7, 2023
Last Updated November 13, 2023
Researcher Emili Castells


The Direct Checkout – Quick View – Buy Now For WooCommerce plugin for WordPress is vulnerable to Stored Cross-Site Scripting via custom CSS code in versions up to, and including, 1.5.8 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with shop manager-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.



1 affected software package

Software Type Plugin
Software Slug quick-view-and-buy-now-for-woocommerce (view on
Patched? Yes
Remediation Update to version 1.5.9, or a newer patched version
Affected Version
  • <= 1.5.8
Patched Version
  • 1.5.9

All the threat data shared in this database is powered by Wordfence Intelligence Enterprise.
Interested in integrating this data into your platform or network?
Contact us now to discuss API access to our Wordfence Intelligence Enterprise Data Feeds.

Inquire Now

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.