Quiz And Survey Master <= 7.3.10 - Missing Authorization

4.3
Missing Authorization
CVE CVE-2022-41652
CVSS 4.3 (Medium)
Publicly Published October 21, 2022
Last Updated February 2, 2023
Researcher Thura Moe Myint - Patchstack Alliance

Description

The Quiz And Survey Master plugin for WordPress is vulnerable to authorization bypass due to a missing user validations on the qsm_clear_audit_data function in versions up to, and including, 7.3.10. This makes it possible for unauthenticated attackers to invoke this function and clear audit log data.

References

Share

1 affected software package

Software Type Plugin
Software Slug quiz-master-next (view on wordpress.org)
Patched? Yes
Remediation Update to version 7.3.11, or a newer patched version
Affected Version
  • <= 7.3.10
Patched Version
  • 7.3.11

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.

Documentation