Quiz And Survey Master <= 8.1.18 - Multiple Cross-Site Request Forgery

Cross-Site Request Forgery (CSRF)
CVSS 5.4 (Medium)
Publicly Published November 8, 2023
Last Updated November 8, 2023


The Quiz And Survey Master – Best Quiz, Exam and Survey Plugin for WordPress plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 8.1.18. This is due to missing or incorrect nonce validation on multiple functions. This makes it possible for unauthenticated attackers to show disabled contact fields and delete quiz results via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.



1 affected software package

Software Type Plugin
Software Slug quiz-master-next (view on wordpress.org)
Patched? Yes
Remediation Update to version 8.1.19, or a newer patched version
Affected Version
  • <= 8.1.18
Patched Version
  • 8.1.19

All the threat data shared in this database is powered by Wordfence Intelligence Enterprise.
Interested in integrating this data into your platform or network?
Contact us now to discuss API access to our Wordfence Intelligence Enterprise Data Feeds.

Inquire Now

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.