Quiz And Survey Master – Best Quiz, Exam and Survey Plugin for WordPress <= 7.3.4 - Insecure Direct Object Reference

Authorization Bypass Through User-Controlled Key
CVE CVE-2021-36865
CVSS 5.4 (Medium)
Publicly Published September 29, 2022
Last Updated February 2, 2023
Researcher Ngo Van Thien - Patchstack Alliance


The Quiz And Survey Master plugin for WordPress is vulnerable to insecure direct object reference in versions up to, and including, 7.3.4. This is due to insufficient validation on the key controlling a quiz's id. This makes it possible for authenticated attackers with author-level capabilities and above to change arbitrary quiz content.



1 affected software package

Software Type Plugin
Software Slug quiz-master-next (view on wordpress.org)
Patched? Yes
Remediation Update to version 7.3.5, or a newer patched version
Affected Version
  • <= 7.3.4
Patched Version
  • 7.3.5

All the threat data shared in this database is powered by Wordfence Intelligence Enterprise.
Interested in integrating this data into your platform or network?
Contact us now to discuss API access to our Wordfence Intelligence Enterprise Data Feeds.

Inquire Now

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.