Quiz And Survey Master – Best Quiz, Exam and Survey Plugin for WordPress <= 9.0.1 - Authenticated (Contributor+) SQL Injection

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection')
CVE CVE-2024-3592
CVSS 9.9 (Critical)
Publicly Published June 6, 2024
Last Updated July 3, 2024
Researcher Lucio Sá


The Quiz And Survey Master – Best Quiz, Exam and Survey Plugin for WordPress plugin for WordPress is vulnerable to SQL Injection via the 'question_id' parameter in all versions up to, and including, 9.0.1 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for authenticated attackers, with contributor-level access and above, to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database. CVE-2024-5606 appears to be a duplicate of this issue.



Vulnerability Details for Quiz and Survey Master (QSM) – Easy Quiz and Survey Maker

Software Type Plugin
Software Slug quiz-master-next (view on wordpress.org)
Patched? Yes
Remediation Update to version 9.0.2, or a newer patched version
Affected Version
  • <= 9.0.1
Patched Version
  • 9.0.2

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.