Quotes llama <= 0.7 - Authenticated (Admin+) Cross-Site Scripting

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
CVE CVE-2022-1566
CVSS 4.8 (Medium)
Publicly Published May 10, 2022
Last Updated January 22, 2024
Researcher Benachi


The Quotes llama WordPress plugin through 0.7 does not sanitise and escape Quotes, which could allow high privilege users such as admin to perform Cross-Site Scripting attacks even when unfiltered_html is disallowed. The attack could also be performed by tricking an admin to import a malicious CSV file



Vulnerability Details for Quotes llama

Software Type Plugin
Software Slug quotes-llama (view on wordpress.org)
Patched? Yes
Remediation Update to version 1.0.0, or a newer patched version
Affected Version
  • <= 0.7
Patched Version
  • 1.0.0

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.