Rating Widget Plugin < 2.9.0 - Sensitive Information Disclosure

Information Exposure
CVSS 5.3 (Medium)
Publicly Published October 30, 2017
Last Updated January 22, 2024
Researcher Mallory Adams - DXW Security


The Rating Widget plugin for WordPress is vulnerable to Sensitive Data Exposure in versions up to, and including, 2.8 via the 'rwdbg' parameter. This can allow unauthenticated attackers to extract sensitive data including usernames, paths, and themes of the plugins.



Vulnerability Details for Rating-Widget: Star Review System

Software Type Plugin
Software Slug rating-widget (view on wordpress.org)
Patched? Yes
Remediation Update to version 2.9.0, or a newer patched version
Affected Version
  • < 2.9.0
Patched Version
  • 2.9.0

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.