Really Simple SSL <= 7.2.3 - Authenticated (Admin+) Server-Side Request Forgery

Server-Side Request Forgery (SSRF)
CVE CVE-2024-31229
CVSS 5.5 (Medium)
Publicly Published April 16, 2024
Last Updated April 25, 2024
Researcher Ananda Dhakal


The Really Simple SSL plugin for WordPress is vulnerable to Server-Side Request Forgery in all versions up to, and including, 7.2.3. This makes it possible for authenticated attackers, with administrator-level access and above, to make web requests to arbitrary locations originating from the web application which can be used to query and modify information from internal services.



Vulnerability Details for Really Simple SSL – Simple and Lightweight Security

Software Type Plugin
Software Slug really-simple-ssl (view on
Patched? Yes
Remediation Update to version 8.0.0, or a newer patched version
Affected Version
  • <= 7.2.3
Patched Version
  • 8.0.0

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.