reCAPTCHA for all <= 1.22 - Missing Authorization via recaptcha_for_all_image_select

4.3
Missing Authorization
CVE CVE-2023-32599
CVSS 4.3 (Medium)
Publicly Published May 15, 2023
Last Updated May 18, 2023
Researcher Jonas Höbenreich

Description

The reCAPTCHA for all plugin for WordPress is vulnerable to unauthorized plugin settings update due to a missing capability check on the recaptcha_for_all_image_select function in versions up to, and including, 1.22. This makes it possible for authenticated attackers , with subscriber-level access and above, to change plugin settings.

References

Share

Vulnerability Details for Cloudflare Turnstile or reCAPTCHA For All Pages, to Block Spam and Hackers Attack, Block Visitors from China

Software Type Plugin
Software Slug recaptcha-for-all (view on wordpress.org)
Patched? Yes
Remediation Update to version 1.23, or a newer patched version
Affected Version
  • <= 1.22
Patched Version
  • 1.23

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.

Documentation