ReDi Restaurant Reservation <= 24.0128 - Cross-Site Request Forgery via redi_restaurant_admin_options_page()

Cross-Site Request Forgery (CSRF)
CVE CVE-2024-31299
CVSS 4.3 (Medium)
Publicly Published April 5, 2024
Last Updated April 11, 2024
Researcher Majed Refaea


The ReDi Restaurant Reservation plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 24.0128. This is due to missing or incorrect nonce validation on the redi_restaurant_admin_options_page() function. This makes it possible for unauthenticated attackers to modify the plugin's settings via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.



Vulnerability Details for ReDi Restaurant Reservation

Software Type Plugin
Software Slug redi-restaurant-reservation (view on
Patched? Yes
Remediation Update to version 24.0303, or a newer patched version
Affected Version
  • <= 24.0128
Patched Version
  • 24.0303

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.