Related Posts for WordPress <= 2.0.3 - Reflected Cross-Site Scripting

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
CVE CVE-2021-24180
CVSS 5.4 (Medium)
Publicly Published March 15, 2021
Last Updated January 22, 2024
Researcher Nguyen Anh Tien - Sun* Cyber Security Research


Unvalidated input and lack of output encoding within the Related Posts for WordPress plugin before 2.0.4 lead to a Reflected Cross-Site Scripting (XSS) vulnerability within the 'lang' GET parameter while editing a post, triggered when users with the capability of editing posts access a malicious URL.



Vulnerability Details for Related Posts for WordPress

Software Type Plugin
Software Slug related-posts-for-wp (view on
Patched? Yes
Remediation Update to version 2.0.4, or a newer patched version
Affected Version
  • <= 2.0.3
Patched Version
  • 2.0.4

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.