Related Posts for WordPress <= 2.0.4 - Stored Cross-Site Scripting

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
CVE CVE-2021-24482
CVSS 5.5 (Medium)
Publicly Published May 17, 2021
Last Updated January 22, 2024
Researcher Vladislav Pokrovsky (ΞX.MI) - Independent AppSec Researcher


The Related Posts for WordPress plugin through 2.0.4 does not sanitise its heading_text and CSS settings, allowing high privilege users (admin) to set XSS payloads in them, leading to Stored Cross-Site Scripting issues.



Vulnerability Details for Related Posts for WordPress

Software Type Plugin
Software Slug related-posts-for-wp (view on
Patched? Yes
Remediation Update to version 2.0.5, or a newer patched version
Affected Version
  • <= 2.0.4
Patched Version
  • 2.0.5

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.