Image Optimizer <= 0.4.6 - Cross-Site Request Forgery

Cross-Site Request Forgery (CSRF)
CVE CVE-2022-2449
CVSS 8.8 (High)
Publicly Published October 26, 2022
Last Updated December 20, 2022
Researcher Raad Haddad - Cloudyrion GmbH


The Image Optimizer plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 0.4.6. This is due to missing or incorrect nonce validation on several AJAX calls. This makes it possible for unauthenticated attackers to invoke those functions to do things like process images and delete/restore back-ups created by the pluign, via forged request granted they can trick a site administrator into performing an action such as clicking on a link.



Vulnerability Details for : The original free image compressor and optimizer plugin

Software Type Plugin
Software Slug resmushit-image-optimizer (view on
Patched? Yes
Remediation Update to version 0.4.7, or a newer patched version
Affected Version
  • <= 0.4.6
Patched Version
  • 0.4.7

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.