Five Star Restaurant Reservations <= 2.4.11 - Missing Authorization to Stored Cross-Site Scripting

Missing Authorization
CVE CVE-2022-0421
CVSS 7.2 (High)
Publicly Published October 31, 2022
Last Updated January 22, 2024
Researcher Krzysztof Zając - CERT PL


The Five Star Restaurant Reservations plugin for WordPress is vulnerable to authorization bypass due to a missing capability check on the rtb_stripe_pmt_succeed AJAX action in versions up to, and including, 2.4.11. This makes it possible for unauthenticated attackers to inject malicious JavaScript, that will execute whenever a user accesses the rtb-bookings page.



1 affected software package

Software Type Plugin
Software Slug restaurant-reservations (view on
Patched? Yes
Remediation Update to version 2.4.12, or a newer patched version
Affected Version
  • <= 2.4.11
Patched Version
  • 2.4.12

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.