Five Star Restaurant Reservations <= 2.6.16 - Missing Authorization

Missing Authorization
CVE CVE-2024-33596
CVSS 4.3 (Medium)
Publicly Published April 25, 2024
Last Updated May 1, 2024
Researcher Steven Julian


The Five Star Restaurant Reservations plugin for WordPress is vulnerable to unauthorized access due to a missing capability check on several functions in versions up to, and including, 2.6.16. This makes it possible for unauthenticated attackers to perform unauthorized actions.



Vulnerability Details for Five Star Restaurant Reservations – WordPress Booking Plugin

Software Type Plugin
Software Slug restaurant-reservations (view on
Patched? Yes
Remediation Update to version 2.6.17, or a newer patched version
Affected Version
  • <= 2.6.16
Patched Version
  • 2.6.17

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.