Restrict for Elementor <= 1.0.7 - Protection Mechanism Bypass

Information Exposure
CVE CVE-2024-0910
CVSS 5.3 (Medium)
Publicly Published June 5, 2024
Last Updated July 1, 2024
Researcher Francesco Carlucci


The Restrict for Elementor plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 1.0.7 due to improper restrictions on hidden data that make it accessible through the REST API. This makes it possible for unauthenticated attackers to extract potentially sensitive data from post content.



Vulnerability Details for Restrict for Elementor

Software Type Plugin
Software Slug restrict-for-elementor (view on
Patched? Yes
Remediation Update to version 1.0.8, or a newer patched version
Affected Version
  • <= 1.0.7
Patched Version
  • 1.0.8

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.