Royal Elementor Addons <= 1.3.59 - Cross-Site Request Forgery to Menu Template creation

4.3
Cross-Site Request Forgery (CSRF)
CVE CVE-2022-4707
CVSS 4.3 (Medium)
Publicly Published January 10, 2023
Last Updated January 28, 2023
Researcher Ramuel Gall

Description

The Royal Elementor Addons plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 1.3.59. This is due to missing nonce validation in the 'wpr_create_mega_menu_template' AJAX function. This allows unauthenticated attackers to create Mega Menu templates, granted they can trick an administrator into performing an action, such as clicking a link.

References

Share

1 affected software package

Software Type Plugin
Software Slug royal-elementor-addons (view on wordpress.org)
Patched? Yes
Remediation Update to version 1.3.60, or a newer patched version
Affected Version
  • <= 1.3.59
Patched Version
  • 1.3.60

All the threat data shared in this database is powered by Wordfence Intelligence.
Interested in integrating this data into your platform or network?
Contact us now to discuss API access to our Wordfence Intelligence Data Feeds.

Inquire Now

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence Community Edition WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.

Documentation