Royal Elementor Addons <= 1.3.59 - Insufficient Access Control to Plugin Deactivation

Improper Access Control
CVE CVE-2022-4702
CVSS 5.4 (Medium)
Publicly Published January 10, 2023
Last Updated February 3, 2023
Researcher Ramuel Gall - Wordfence


The Royal Elementor Addons plugin for WordPress is vulnerable to insufficient access control in the 'wpr_fix_royal_compatibility' AJAX action in versions up to, and including, 1.3.59. This allows any authenticated user, including those with subscriber-level permissions, to deactivate every plugin on the site unless it is part of an extremely limited hardcoded selection. This also switches the site to the 'royal-elementor-kit' theme, potentially resulting in availability issues.



1 affected software package

Software Type Plugin
Software Slug royal-elementor-addons (view on
Patched? Yes
Remediation Update to version 1.3.60, or a newer patched version
Affected Version
  • <= 1.3.59
Patched Version
  • 1.3.60

All the threat data shared in this database is powered by Wordfence Intelligence Enterprise.
Interested in integrating this data into your platform or network?
Contact us now to discuss API access to our Wordfence Intelligence Enterprise Data Feeds.

Inquire Now

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.