Royal Elementor Addons <= 1.3.59 - Insufficient Access Control to Plugin Deactivation

5.4
Improper Access Control
CVE CVE-2022-4702
CVSS 5.4 (Medium)
Publicly Published January 10, 2023
Last Updated January 22, 2024
Researcher Ram - Wordfence

Description

The Royal Elementor Addons plugin for WordPress is vulnerable to insufficient access control in the 'wpr_fix_royal_compatibility' AJAX action in versions up to, and including, 1.3.59. This allows any authenticated user, including those with subscriber-level permissions, to deactivate every plugin on the site unless it is part of an extremely limited hardcoded selection. This also switches the site to the 'royal-elementor-kit' theme, potentially resulting in availability issues.

References

Share

Vulnerability Details for Royal Elementor Addons and Templates

Software Type Plugin
Software Slug royal-elementor-addons (view on wordpress.org)
Patched? Yes
Remediation Update to version 1.3.60, or a newer patched version
Affected Version
  • <= 1.3.59
Patched Version
  • 1.3.60

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.

Documentation