Royal Elementor Addons <= 1.3.59 - Reflected Cross-Site Scripting

6.1
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
CVE CVE-2022-4710
CVSS 6.1 (Medium)
Publicly Published January 10, 2023
Last Updated January 28, 2023
Researcher Ramuel Gall

Description

The Royal Elementor Addons plugin for WordPress is vulnerable to Reflected Cross-Site Scripting in versions up to, and including, 1.3.59, due to due to insufficient input sanitization and output escaping of the 'wpr_ajax_search_link_target' parameter in the 'data_fetch' function. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link. This is occurring because 'sanitize_text_field' is insufficient to prevent attribute-based Cross-Site Scripting

References

Share

1 affected software package

Software Type Plugin
Software Slug royal-elementor-addons (view on wordpress.org)
Patched? Yes
Remediation Update to version 1.3.60, or a newer patched version
Affected Version
  • <= 1.3.59
Patched Version
  • 1.3.60

All the threat data shared in this database is powered by Wordfence Intelligence.
Interested in integrating this data into your platform or network?
Contact us now to discuss API access to our Wordfence Intelligence Data Feeds.

Inquire Now

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence Community Edition WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.

Documentation