Royal Elementor Addons <= 1.3.75 - Cross-Site Request Forgery

Cross-Site Request Forgery (CSRF)
CVE CVE-2022-47175
CVSS 4.3 (Medium)
Publicly Published August 22, 2023
Last Updated January 22, 2024
Researcher Muhammad Daffa


The Royal Elementor Addons plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 1.3.75. This is due to missing or incorrect nonce validation on several functions including wpr_rating_dismiss_notice, wpr_rating_already_rated, wpr_pro_features_dismiss_notice. This makes it possible for unauthenticated attackers to invoke these functions via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.



Vulnerability Details for Royal Elementor Addons and Templates

Software Type Plugin
Software Slug royal-elementor-addons (view on
Patched? Yes
Remediation Update to version 1.3.76, or a newer patched version
Affected Version
  • <= 1.3.75
Patched Version
  • 1.3.76

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.