Royal Elementor Addons and Templates <= 1.3.87 - Missing Authorization via wpr_update_form_action_meta

Cross-Site Request Forgery (CSRF)
CVE CVE-2024-0516
CVSS 5.3 (Medium)
Publicly Published February 7, 2024
Last Updated February 20, 2024
Researcher Francesco Carlucci


The Royal Elementor Addons and Templates plugin for WordPress is vulnerable to unauthorized post metadata update due to a missing capability check on the wpr_update_form_action_meta function in all versions up to, and including, 1.3.87. This makes it possible for unauthenticated attackers to update certain metadata.



Vulnerability Details for Royal Elementor Addons and Templates

Software Type Plugin
Software Slug royal-elementor-addons (view on
Patched? Yes
Remediation Update to version 1.3.88, or a newer patched version
Affected Version
  • <= 1.3.87
Patched Version
  • 1.3.88

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.