RT Easy Builder – Advanced addons for Elementor <= 2.0 - Missing Authorization

Missing Authorization
CVE CVE-2024-30484
CVSS 5.3 (Medium)
Publicly Published March 28, 2024
Last Updated April 3, 2024
Researcher Friday


The RT Easy Builder – Advanced addons for Elementor plugin for WordPress is vulnerable to unauthorized plugin activation due to a missing capability check on the ajax_activate_plugins() function in versions up to, and including, 2.0. This makes it possible for authenticated attackers, with subscriber-level access and above, to activate plugins.



Vulnerability Details for RT Easy Builder – Advanced addons for Elementor

Software Type Plugin
Software Slug rt-easy-builder-advanced-addons-for-elementor (view on wordpress.org)
Patched? Yes
Remediation Update to version 2.1, or a newer patched version
Affected Version
  • <= 2.0
Patched Version
  • 2.1

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.