SVG Sanitizer library <= 0.15.4 - Cross-Site Scripting Bypass

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
CVE CVE-2023-28426
CVSS 7.2 (High)
Publicly Published March 23, 2023
Last Updated March 24, 2023
Researcher Cyxow


The SVG Sanitizer library is vulnerable to XSS Bypass in versions up to, and including, 0.15.4. This may allow an attacker to successfully upload an SVG with persistent Cross-Site Scripting payloads in cases where a plugin is using this library to safely process SVG files.



1 affected software package

Software Type Plugin
Software Slug safe-svg (view on
Patched? Yes
Remediation Update to version 2.1.0, or a newer patched version
Affected Version
  • <= 2.0.3
Patched Version
  • 2.1.0

All the threat data shared in this database is powered by Wordfence Intelligence Enterprise.
Interested in integrating this data into your platform or network?
Contact us now to discuss API access to our Wordfence Intelligence Enterprise Data Feeds.

Inquire Now

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.