Salon booking system <= 9.9 - Unauthenticated Arbitrary File Deletion

9.1
Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal')
CVE CVE-2024-4442
CVSS 9.1 (Critical)
Publicly Published May 17, 2024
Last Updated June 6, 2024
Researcher István Márton - Wordfence

Description

The Salon booking system plugin for WordPress is vulnerable to arbitrary file deletion in all versions up to, and including, 9.8. This is due to the plugin not properly validating the path of an uploaded file prior to deleting it. This makes it possible for unauthenticated attackers to delete arbitrary files, including the wp-config.php file, which can make site takeover and remote code execution possible. This was partially patched in 9.9, and sufficiently patched in 10.0.

References

Share

Vulnerability Details for Salon Booking System

Software Type Plugin
Software Slug salon-booking-system (view on wordpress.org)
Patched? Yes
Remediation Update to version 10.0, or a newer patched version
Affected Version
  • <= 9.9
Patched Version
  • 10.0

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.

Documentation