Sassy Social Share <= 3.3.3 - Reflected Cross-Site Scripting

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
CVSS 6.1 (Medium)
Publicly Published November 29, 2022
Last Updated December 20, 2022
Researcher Nicholas Mun (NRockhouse) - Across Verticals


The Sassy Social Share plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the 'urls' parameter called via the 'heateor_sss_sharing_count' AJAX action in versions up to, and including, 3.3.3 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.

Wordfence blocked 1,305 attacks targeting this vulnerability in the past 24 hours.



Vulnerability Details for Social Sharing Plugin – Sassy Social Share

Software Type Plugin
Software Slug sassy-social-share (view on
Patched? Yes
Remediation Update to version 3.3.4, or a newer patched version
Affected Version
  • <= 3.3.3
Patched Version
  • 3.3.4

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.