Animator <= 3.0.10 - Missing Authorization to Plugin Settings Update

Missing Authorization
CVE CVE-2023-47689
CVSS 5.3 (Medium)
Publicly Published November 9, 2023
Last Updated November 20, 2023
Researcher Elliot


The Animator plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the sta_update_options() function in versions up to, and including, 3.0.10. This makes it possible for subscribers to modify the plugin's settings. Version 3.0.9 used to provide a nopriv action hook, which allowed unauthenticated individuals to perform this task.



1 affected software package

Software Type Plugin
Software Slug scroll-triggered-animations (view on
Patched? Yes
Remediation Update to version 3.0.11, or a newer patched version
Affected Version
  • <= 3.0.10
Patched Version
  • 3.0.11

All the threat data shared in this database is powered by Wordfence Intelligence Enterprise.
Interested in integrating this data into your platform or network?
Contact us now to discuss API access to our Wordfence Intelligence Enterprise Data Feeds.

Inquire Now

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.